Webservice Connector Provisioning is failing with the error CombinedContainer is missing

Hi Team,

I am working on webservice connector. But when i submit the request for create operation, it is failing with the error below

“domain”: “global”,
“message”: “Error parsing ProtoRPC request (Unable to parse request content: Message CombinedContainer is missing required field office_id)”,
“reason”: “badRequest”

Here office_id i am hard coding and it is 16 digit number. Below things i tried to fix the issue

1)I tried to create the account from postman it is working
2)I tried to write a java code to create the account at target and it is working.

only when i tried to provision the account through connector it is failing with 400 bad request.

anyone suggest me if i missing anything in the configuration?

It might be a good idea to enable some logging.

Can you enable logging for the following packages:


You should be able to see the content of the request sent and compare it to postman and your java code.

– Remold

Hi @nabolla2

We might need more information to help you with this issue. Please share the application xml masking the sensitive information, the logs and the expected json body. This will help us to debug the issue and help you :slightly_smiling_face:

Thanks for your response Remold. I have enabled and got the logs. I am investigating the issue.

Thanks for your response Jarin. I have enabled and got the logs. I am investigating the issue.

Hi Naga. Any updates on your issue?

Hi Colin,

Issue got fixed. I have enabled some plan compiler logs and i have found some special characters are going along with Json. So i have removed that.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.