ServiceDesk Integration: Issues/Errors during creation of RITM



Hi Team,

Earlier, we are able to create tickets from SailPoint to ServiceNow via SDIM with all the required fields w/o any hassles.
However, offlate, we are getting either of the attached 2 errors and not able to create the RITM.

Even if the RITM is triggered from SailPoint, there are some fields missing in the RITM which were populating earlier.

Seek your inputs on this.

Thanks,
Kartheek

Hi @kartheek_gopu,

It’s seems like an authentication problem.

Is your refresh token is valid ?

Hi @kartheek_gopu,

I suspect this can be due to password expiration of the service account. Could you please try resetting the password for the service account and update the same in the ISC’s SDIM.

If you are using OAuth 2.0 once re-generate the client credentials post resetting the password.

Thank you.
Shanmukh

We are using basic authentication. Also, we have checked the credentials and the same are working.

We are using basic authentication. Also, we have checked the credentials and the same are working.

Hi @kartheek_gopu,

Have you updated the default velocity script configured for “Description” field in SDIM? I have you have encountered seaspray error (line 1, cloumn 21) for $ou. Can you check if the ticket is being generated successfully using the default configurations for the same service account? If yes, share your updated velocity script to fix the issue.

Thank you.
Shanmukh Gali

Hi,
I think there is some bug in the Service Desk Integeration. If you are updating anything on the Service Desk configuration re-enter the password again in the Service Desk. Somehow IdentityNow is blanking out the password after we are updating any configutation on the service desk. Try to reenter your password it should fix your issue

We started experiencing the same issue at the beginning of May. Re-entering the password (which didn’t change) seems to resolve for a period of time. The issue resurfaced again today. When we submitted a case the first time, SailPoint didn’t have any feedback really other than to reset the password which resolved it. We don’t know however, what the root cause is.

Did you submit a case and if so, have they said anything about this?

Hi,
By re-entering the password whenever the SDIM is opened, we are ensuring that the error is not resurfaced. This has taken a week time to understand this !!! However, still not sure of the root cause for this(tried in different browsers). Taken up with SailPoint along with our observation who are yet to revert on this.

1 Like

We also are noticing that pattern. When you open SDIM whether you make a change or not, just opening it the password has to be entered otherwise the error.

1 Like