Custom Authentication issue with WebService Connector

Hi,

We are integrating webservice connector in IDN. The webservice application follows below authentication process-
1- Provide the username and password and hit the url which will return the SessionId in response
2- Use this sessionId to invoke other operations.

Below is the config we have done in Identity Now-
1- Authentication type- No/CustomAuthentication
2- Custom Authentication Operation has below config-




3- For other operation, like Test Connection or Account Aggregation we have configured the headers as-

Every time we try to run the aggregation it failed with the error-
image

However if we do TestConnection first and then Run Aggregation it works fine. So it seems the sessionId is not getting populated for Aggregation when run without doing TestConnection. We verified this by putting logs too.
We also tried to add the error codes as we read on compass about it, but this also didnot resolve the issue.

Kindly let us know if anyone faced the same issue or has any insights.

Thanks
Yunus

Hi Yunus, Are you able to fix this issue?

Hi,

Yes, we were able to resolve the issue by adding the possible Http error codes.
Just check what error message your api throws like INVALID_SESSION ID and error codes like 402,403 etc. Just add them from the UI and hopefully it will resolve for you.

custom authentication by default regenerates token only on 401 error code so if your end system is sending another error code it would not retry token generation OOTB.

Test connection works fine. But in account aggregation, its not taking the sessionId from custom authentication. From the logs, I could see its not executing the CustomAuthentication operation before account aggregation.sequenceNumberForEndpoint is also in correct order.

Hi @Manju22,

Were you able to fix this somehow?, thanks.

Yes, our source supported Basic Authorization Authorization {sessionId} and Bearer Token Authorization Authorization Bearer {sessionId}

Adding Authorization as
Bearer $application.accesstoken$

Also added HTTP Errors

errorMessages

Invalid or expired session ID., INVALID_SESSION_ID

errorCodes