SaaS Connector issue

I created a SaaS Connector. I uploaded it to our Sandbox and it is functioning as expected. I uploaded the same code to Production. In production, I am not able to create a new Source from the new Connector. I get the prompts and enter Name, Description, Owner. I fill that out, and click Continue, and immediately I get an error with a tracking code. I tried running a Validate on the connector in Production, and received the following:

HTTP error: {"detailCode":"Bad Request","trackingId":"ed072400a2604ea3a2938379a111cca4","messages":[{"locale":"en-US","localeOrigin":"DEFAULT","text":"[ConnectorError] error receiving response from connector: %!s(\u003cnil\u003e) (connector process may have crashed)"}]}

To me this looks like there is an issue with the Tenant. Support has been no help. Has anyone run into this issue?

Hi Carl, looking through the logs, it appears the connector is throwing the error in your code:
May 22, 2023 @ 09:59:14.509 error loading connector: disablementChoice must be provided from config, Error: disablementChoice must be provided from config
Please check and make sure you are sending the right details and try again. Also, if you use the sail conn logs command, it will surface these types of messages so you can see what is happening with your connector. You can read more about it here.

Thank you for the reply. I did notice that last night, and added it to my config file, but still had issues with getting it to work in our Production tenant.

This morning I realized that I initiated the SaaS connector using the CLI while connected to Sandbox. I tried initializing a new connector while connected to Production. I copied my code over to this newly initiated project. I compiled it and uploaded it to Production, and I was able to create the source normally.

Not sure if there is a difference between initiating in sandbox vs production, or if something else was hung up. But it is working for me now.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.