Modify Application definition UI

Hello guys,

I’ve Sailpoint IdentityIQ version 8.1p3 . As requirement, my client wants to add an additional column in the application definition table. I already extended a new attribute (Global setting > Application attribute) and then I added the new column in UIConfig ().

The new column appears but is empty, Im not able to display any value. Any idea?


Hi Beatriz -

So there are a few moving parts when it comes to extending object classes, especially when you want them to show up in the UI.

Assuming that when you added this new attribute it was marked as searchable and IIQ automatically assigned an extended column to it (which can be validated by opening up the Application ObjectConfig object via debug – there should be a “extendedNumber” entry for the new attribute you created e.g. extendedNumber=“1”), then all that remains is adding an actual value for the attribute to an application.

You can set an attribute value a few different ways, but here are two –

  1. If you marked the attribute as “Editable” when you created it, then all you have to do is open up one application via Applications > Application Definition in the UI, enter a value in the field next to your new attribute, and click save.
  2. If the attribute was not marked as “Editable”, you could make this update via debug pages. To do that, navigate to the debug pages, open up a given application object, add an entry under the Application’s Attributes Map e.g. where the key is the name of your new attribute and the value is some value that matches the attribute type you created, and click save.

If after you try these updates you’re still unable to see the values in the UI, please reply back with the entry for new attribute from the Application ObjectConfig as well as the changes you made to the UIConfig object and we can troubleshoot from there.

If all else fails, it wouldn’t be a bad idea to review the documentation for these sorts of changes here - ExtendedAttributesDoc - and here - UIConfigDoc

Best of luck!


1 Like

Hello Austin,

Thank you for your explanation. Finally I was able to display the attribute, I forgot to add the parameter property.