Disable SailPoint Source Status API call

I am calling the API: /account/provision/:id with the id from a search result, xxxx in this example:

“id”: “xxxx”,
“source”: {
“name”: “IdentityNow”,
“id”: “yyyyy”,
“type”: “IdentityNowConnector”

This APPEARS to work, since the SailPoint source is showing as Disabled in the UI.
BUT, it doesn’t really update the source. I get the same number of identities when I run the query, and after a refresh, the SailPoint source goes back to Enabled for he user.

Is there something else that needs to be done?


Some additional information.
Here is the body from the POST call:

“accessRequestId”: “aaaaaaa”,
“caseName”: “Cloud LCM Provisioning”,
“launchStatus”: “executing”,
“launcher”: “Chris.Peterson”,
“messages”: ,
“resultDetails”: {
“attributes”: {
“identityRequestId”: “bbbbb”,
“workflowCaseId”: “ccccc”
“completed”: null,
“completionStatus”: null,
“created”: 1631213057104,
“description”: “Workflow Case”,
“id”: “ddddd”,
“launched”: 1631213056745,
“launcher”: “Chris.Peterson”,
“messages”: ,
“name”: “Cloud LCM Provisioning - 9bb1d2ce1876452a8d4bbf173a3e50c5”,
“parentName”: null,
“progress”: null,
“returns”: [
“attributeName”: “case”,
“displayLabel”: “CASE”
“type”: “QUARTZ”
“sessionOwner”: null,
“variables”: null

And the user has a “Disable Account Passed” Action for the IdentityNow Application in the Activity tab. But the Account is still showing as Enabled.

I’m not familiar with this API. Is it a v3 or beta?

The base is:


and it’s a POST for /account/provision/:id
with the postData: “disabled=true”

This is what the UI is using for the Disable Account on the Accounts tab.


I think this may have been caused by another issue with our tenant, whicjh caused some actions to be inconsistent. That has been corrected, and now the API call works to successfully disable the account.

When I did the disable through the API, and through the UI, the accounts stayed disabled after a Refresh.