Complete In Progress Tasks


I have few tasks stuck in my tenant that i would like to complete.

I’ve always followed this doc - [IdentityNow] Identity data is continuously updating - Knowledge Portal but now i receiving error 500.

```curl --location --request PATCH 'https://<tenant><event_id>' \
--header 'Content-Type: application/json-patch+json' \
--header 'Authorization: Bearer  <token>' \
--data-raw '[
        "op": "replace",
        "path": "/completionStatus",
        "value": "Success"

Anyone facing the same issue?

Hey Yan,

I have run into this before when trying to bulk close tasks. I never figured out what exactly caused it to happen, but the task was still updated from my PATCH operation. Can you check the task again and see if it updated despite the NullPointerException error?

Thank you,

  • Zach

Additionally, as a helpful tip, since completing a task requires you to update both the completionStatus and the completed fields, you can bundle them into one operation instead of making 2 separate calls as described in the documentation you referenced. I tested this body out and it works fine.

		"op": "replace",
		"path": "/completionStatus",
		"value": "Success"
		"op": "replace",
		"path": "/completed",
		"value": "2024-04-05T12:00:00.000Z"

That’s nice to know, thank you for share!

It worked, that’s odd but i manage to edit my applications!

Thank you!

It is definitely some odd behavior, but I’m glad your updates still worked also!

@colin_mckibben Is this something that would be worth opening a ticket for? It kind of seems like a bug, but I wanted to see if you had any thoughts on the root cause of this in case it was expected behavior. Yan and I have both noticed that when running PATCH operations to update tasks, a NullPointerException error is sometimes returned with a 500 code, but the PATCH operation still passes successfully for updating the task.

1 Like

Yes, this is worth an investigation to get it fixed. What would help is if you can reproduce the issue and tell us either the trace ID, if there is one, or when you executed the API and in what tenant so we can check the logs. You can submit your bug report to Bugs and I can forward it on to the appropriate team.

Thanks Colin!

I just submitted this bug report. Let me know if there is any more info I can help supply!