Adding Application Description to report results of the custom report

Which IIQ version are you inquiring about?

Version 8.3

Share all details related to your problem, including any error messages you may have received.

Hello all, I’ve been trying to add “Application Description” to Report results of a Custom report
I’ve set DataSource as Application and type as Filter
And added below line in columns section

Tried adding application.description to property but no luck


aused by: could not resolve property: description of: sailpoint.object.Application
at ~[identityiq.jar:8.3 Build f4b330b4da3-20220427-175259]
at ~[identityiq.jar:8.3 Build f4b330b4da3-20220427-175259]

Could someone please help me with this

I believe you used description attribute in filter which is not a searchable attribute in Application object which created this error.

Thanks for the swift response krishna,Any ideas on how to achieve this requirement in some other way


Please try this, I assume your Filter source is Application and language selected at UI description level is English(United States)

    <ReportColumnConfig field="appdescrition" header="Application Description" property="name" sortable="true" width="110">
                    import sailpoint.object.TaskResult;
                    import sailpoint.object.TaskDefinition;
                    Application appObj = context.getObjectByName(Application.class, value);
                    return appObj.getDescription("US");

This should work, do let me know if you see any issue.

If this worked, please mark the solution so that it will help others.

I tried it Satish,unfortunately i wasn’t able to findthe new column in Report results

Can you please share the report Task Definition xml

Did you create a new report using this updated template or edited the current report and selected this column to results?

Basically you report should have the new column in the below tag in the below

  <entry key="reportColumnOrder" value="Column1,....Column10"/>

This is your report template Task Definition, I am requesting for Report xml where you are referencing this task definition as parent.

Got it Satish,I edited already existing Report instance and tried running it due to which the issue has occured.

Thank you so much

ya, Got the same doubt, anyhow Glad it worked :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.