Getting error for a report after upgrading to 8.4

Which IIQ version are you inquiring about?

Version 8.4

Share all details related to your problem, including any error messages you may have received.

We are getting below report for a report after upgrading to 8.4

Report is to get the identity details: Error preparing ProjectionDataSource
at sailpoint.reporting.JasperCsvWriter.write(
at sailpoint.reporting.LiveReportExecutor.execute(
at sailpoint.api.TaskManager.runSync(
at sailpoint.api.TaskManager.runSync(
at sailpoint.scheduler.JobAdapter.execute(
at org.quartz.simpl.SimpleThreadPool$
Caused by: net.sf.jasperreports.engine.JRException: Error preparing ProjectionDataSource
at sailpoint.reporting.JasperCsvWriter.write(
… 6 more
Caused by: Could not find class for join property extendedAttribute in packages [sailpoint.object, sailpoint.object.accesshistory]
at sailpoint.reporting.datasource.ProjectionDataSource.prepare(
… 7 more
Caused by: java.lang.RuntimeException: Could not find class for join property extendedAttribute in packages [sailpoint.object, sailpoint.object.accesshistory]
at sailpoint.persistence.HQLFilterVisitor.getClassFromProperty(
at sailpoint.persistence.HQLAliasContextImpl.substituteAlias(
at sailpoint.persistence.HQLAliasContextStack.substituteAlias(
at sailpoint.persistence.HQLFilterVisitor.addSelectColumns(
at sailpoint.persistence.HQLFilterVisitor.getQueryString(

Hi @pguptatd

Try to get more logs

  • enable the detailed Access History logging by changing in log4j2
  • try again and see if you will get some more logs.

Also try to turn off the access History from system configuration and see if it works. something related to upgrade steps got missed.

Also, If possible then provide the report name. will try to see in my local of 8.4.

Let us know if you have some data.

Did you run the IIQ console extended schema after the upgrade? After generating the extended schema attributes, you should run the database scripts in your database. This report should work after restarting your servers.


What is your extended Property name in the error, looks like there is an existing bug if your extended property starts with Upper Case, is it possible to share the report xml

All of our extended attributes are already in DB and up to date.
Already have checked the logs but it keeps on throwing error.
@satish yes the extended attributes names are in capital for which it is throwing error.

Do you know the fix for the same?

Access History is already disabled in our system


Thats the issue, it is a known issue, check below link.

Either you create a new one with lower case and change all your config and drop this or Modify the name in all places, configurations as temporary fix.

Solved: Could not find class for join property “attribute name” in packages [sailpoint.object] - Compass

Also recommendation is always use lower case or CamelCase for any extended attribute names.

Hibernate tends to translate upper case letters to class names and lower case to property names.

Please do changes suggested in above comment and let me know if that worked.

I don’t think that is the case in this case.
As same works with 8.1 and 8.2 version

Are you able to reproduce this issue in any Sandbox or Dev environment, if so I suggest you to try what I mentioned above in Dev or Sandbox because looking at the error this more or less the same what happened for me earlier as well, I understood this is not the case with your earlier version but if we give a try in sandbox or Dev , that way we can get to a conclusion

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.