Workflow not triggering from Request Center

I have developed a simple workflow in sandbox environment to trigger when user request for a role. Workflow is working when we perform ‘Test Workflow’, but when user raise request from ‘Request Center’ then role is getting assigned without workflow execution.
This workflow uses ‘Access Request Decision’ trigger with filter ‘$.requestedItemsStatus[?(@.type == ‘ROLE’)]’. I tried with ‘Role’ (along with single and double quotes). I don’t find any executions available when requested from ‘Request Center’, but available when we perform ‘Test Workflow’.
Also, tried with filter '$.requestedItemsStatus[?( == ‘Test Sample Role Request’)]
Note: Workflow is ‘Enabled’ before testing.
Can anyone let us know what could be the issue in this case?

Hi @kalyanmutya,

I just wanted to confirm if Access Review is also enabled for the mentioned Role. The workflow will only be triggered if the reviewer Approves or Rejects the role request.

I can conform ‘Access Review’ is enabled for requested role.
Will workflow trigger if request is auto-approved? I tried with auto-approve and Reviewer approval, but not working.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.