The following access items are not requestable

Marked all the entitlements under my source as requestable and used the entitlements api to verify the same. Now when i submit access requests on those same entitlements I get this message.

The following access items are not requestable: [{entitlement id 1},{entitlement id 2}]

These entitlements (even though are marked as requestable) don’t show up in the request center.

Check if the allowEntitlementRequest flag is set to true under access request config.

You can also do this via the UI under Admin>Global>System Settings>System Features.

Hey Vikram,

Instead of API kindly check it directly from UI
Admin->Access->Entitlements whether the entitlement is marked as requestable or not everything marked as requestable there should show up in request centre.

So, it is weird. The entitlements show as requestable on the source but on the entitlements page those same entitlements show as not requestable. So, I went ahead and made them requestable here as well, but looks like they did not get updated even after almost 20 hrs.

I have had similar issue in the past and it could not be resolved even after opening a ticket with SP. Reset the whole source and recreated the entitlements and it worked.

So earlier i tried removing some entitlements as requestable and then making them requestable again but that didnt work. But then i thought of throwing all the logic in gutter and trying that once again for all the entitlements and then making them requestable again. And it worked … :neutral_face:


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.