ServiceNow Integration error with IdentityNow

Hi All, we are trying to configure the ServiceNow catalog for integration with IDN, but are receiving the error when requesting a role from ServiceNow:

“The Identity ‘[email protected]’ is not available in SailPoint IdentityNow. Please check with Administrators…”

We have the ServiceNow governance connector installed and bringing in ServiceNow account, and the identity exists for ‘[email protected]’.

Checked Permissions of the service account, all good there.

Does anyone have any other suggestions?

Kind Regards,

What do you have set for your correlation attributes on the ServiceNow side?


Hey Mark, thanks for responding, see below:

A couple of things I noticed when querying identities on my own tenant

  1. returns all identities, so something is off with that search

  2. using email (removing attributes.) works, but appears it is case sensitive

I think I ran into this before, and I decided to use an employee number/personnel number attribute to match the two.

Try running some of these queries on your own tenant and see what you get


Hey Mark, thanks for your reply.

We have tried using just ‘email’ in the above IdentityNow attribute field and it results in the same error.

When looking at the email value of both email values of the identity and the ServiceNow account, they are both lowercase and match.

Created a custom Identity attribute for sysid. Tried using sysid and attributes.sysid as the Identity attribute and the sys_id ServiceNow account attribute to correlate but no luck.

My search queries returned just as yours.

In IDN I am just manually correlating the ServiceNow account to it identity for testing purposes.

Any other suggestions based on this information?

Greatly appreciate it!

Only other thing I can think of is to ask what version you have installed on your instance? Because I recall an earlier version had a bug that I found where the system property that stores one of those correlating attributes was misspelled in their code, and they later fixed that.