ServiceNow Integration Config Transport Error 403 Forbidden


We are receiving the below errors while ServiceNow ticketing is triggered

INFO https-jsse-nio-8443-exec-8 axis2.transport.http.HTTPSender:196 - Unable to sendViaPost to url[]
org.apache.axis2.AxisFault: Transport error: 403 Error: Forbidden
at org.apache.axis2.transport.http.HTTPSender.handleResponse(
at org.apache.axis2.transport.http.HTTPSender.sendViaPost(
at org.apache.axis2.transport.http.HTTPSender.send(
at org.apache.axis2.transport.http.CommonsHTTPTransportSender.writeMessageWithCommons(
at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(

We also have a custom rule build on axis2 libraries that generates tickets, we are receiving same error there. Please let me know if anyone has faced same issues. IIQ Version 7.2 p2.

Thank you

Hi @chaitanya - welcome to the developer community!

Usually the 403 errors are indicating that either your auth credentials are invalid, or the account/user you are authenticating to the ServiceNow API’s doesn’t have sufficient permissions to interact with that API. I believe for the service desk integration, the user IIQ connects with needs to have the ‘x_sap_sdim.admin’ role assigned in ServiceNow.

Can you also confirm that the credentials specified in the ‘IdentityIQforServiceNowServiceDesk.xml’ file are correct?

You can reference the ITSM module guide on compass for further details: Sign In to Compass - Compass

@chaitanya, thanks for posting in the community; it’s a delight to have you with us. Please let us know if the above helped to resolve your issue. We would love to hear an update!


Apologies for checking in late, we had a proxy that is blocking the connection to ServiceNow from IIQ servers. After bypassing that proxy ServiceNow connection worked successfully.