Sailpoint CLI Output Types

Using Sailpoint CLI search command with outputTypes option receives error.

Error: unknown flag: --outputTypes

Command used :

sail search query “name:amanda*” --indices identities --outputTypes csv

The command without the outputTypes argument runs successfully. Have tried to run this with json type too and got same error.

I am referring to this documentation: Search | SailPoint Developer Community

Can someone please confirm if this is a bug Or this option isn’t supported?


1 Like

Hi @sharvari
Got exactly same error as you do

As documentation states it is there available

I’ve created bug ticket into the cli repo.

I’ve assigned this to our dev tools team (@dev_tools_team) to look at.

Hey @sharvari, @kjakubiak,

Thank you both for bringing this to our attention.

The outputTypes flag was deprecated as part of the 2.0 release of the CLI, the reason being that CSV is not a valid output format for the level of complexity that occurs in these data sets, and we were having a number of issues in the conversion to CSV.

The only supported output format at the moment is JSON, and thus that flag has been removed.

That being said this is a good lesson going forward, I will look to add documentation to the CLI itself notating when flags are deprecated.

Please let us know if you have any other issues or concerns with the SailPoint CLI

Hey Luke
Can it be removed from the documentation ?
I think still people are following the same documentation on Search | SailPoint Developer Community which is misguiding.

Output Types

Use the outputTypes flag to specify the output data format for the search query results. Currently, the only supported output types are json and csv.