Oracle HCM - API delta aggregation failing

We are having an issue when setting up Oracle HCM connector details.

We are able to do the full aggregation via file upload and test connection appears to work.

When we try run delta aggregation of the API, the following is returned: sailpoint.connector.ConnectorException: Invalid URL, username or password

We have checked the URL, username and password and all seem correct.

As we say, test connection works with Via API Authentication ticked, so don’t believe it is a connection issue.

Have whitelisted the URLs related to oracle HCM. Wondered if anyone had any thoughts on anywhere we can check for logs or experienced a similar issue?

Looking from error as you said credential is correct then it seems that the final URL may be wrong by which you are trying to get user. Can you try to see the final URL in the logs that whether it is in correct format or there are some extra additions.

Thanks

Suspect you right that is the issue, but have tried a few different ones, including the format suggested by sailpoint here

We have tried both of the below (obviously putting in our own config for the URL), we can login via front end, so account is correct

https://{yourOracleCloudDomain}.com
https://{yourOracleCloudDomain}.com/hcmRestApi/atomservlet

Check once this documentation snippet and see if the configuration is as per this documentation.

Also when you say that you are able to access API from UI then is it from HCM UI or from some app like Postman ?

Thanks

Try enabling the logging for the connector specifically, check this page here: https://community.sailpoint.com/t5/IdentityNow-Articles/Enabling-Connector-Logging-in-IdentityNow/ta-p/188107?_ga=2.192633134.549720369.1677512159-1413086531.1675185796&_gl=1*ew0ox7*_ga*MTQxMzA4NjUzMS4xNjc1MTg1Nzk2*_ga_SS72Z4HXJM*MTY3Nzc2ODY4MS42MC4xLjE2Nzc3NzAwNjguNDguMC4w

This should print more details in the ccg log on the VA. I had a similar issue on another Oracle connector where the credentials I had didn’t have access to a specific table. In this case could be a restriction on a URL in the set of APIs maybe.

Just disable Delta aggregation in Source Configuration.

How would that solve the issue as think you need the API delta load for some values?