Introduction to Plugin Development

Additional Resources

5 Likes

Hi, thanks for a good session. The very simple example you showed during the presentation is that available anywhere?

Did one yesterday - easy…
HelloRestPluginSample.tar.gz (3.4 KB)

Will the recording be released sometime next week? Would love to go over this again

Thanks for posting the presentation! Several of the links included at the end of the presentation are giving me a 404:
https://community.sailpoint.com/groups/development-partnership-program
https://community.sailpoint.com/community/plugins (though this one I found separately)

Are those links correct? I tried searching Compass without much success.

1 Like

Hi Christopher - yeah some of these links have expired. I wouldn’t worry too much about the first link.

Here is a .zip of the plugin that was demo’d - please note this isn’t the install file .zip to install the plugin - you’ll need to extract this and then run the ant build script to create that.

PluginExample.zip (30.1 KB)

@adam_creaney can you please point me to the documents for authenticating with the rest endpoints. I am able to authenticate using a username and password, but I am not able to authenticate by passing an oauth token like I can with the scim endpoints. Also, I was wondering if it is possible to perform a custom rule based authentication like we can do with users logging into the application in the ui.

@adam_creaney Im trying to follow up your example:
postman:
http://localhost:8080/identityiq/plugin/rest/PluginExample/getExample

but i get the response → 404 not found

Im trying to get the String
String responseString = “It worked”;

so I comment out all the code related to call Adam.Kennedy

I did some diference from yours on the build.properties it can be related???

line 2: iiq.home=/Users/adam.creaney/Documents/IdentityIQ83/identityiq

this is the location where you install identityiq??? mine is inside tomcat

from the logs I get

WARNING: A provider com.sailpoint.plugin.exampleplugin.rest.ExamplePluginRestManager registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider com.sailpoint.plugin.exampleplugin.rest.ExamplePluginRestManager will be ignored.
jul. 04, 2023 4:01:04 P.M. org.apache.catalina.core.StandardWrapperValve invoke

Thank in advance

Hello, when using Postman and setting the baseUrl, it is supposed to be the url to IdentityIQ? When following your example, I get no response in form of json, I get our entire page on IIQ: