Identity Attributes

Which IIQ version are you inquiring about?

Version 8.3

Please share any images or screenshots, if relevant.

Share all details related to your problem, including any error messages you may have received.

hi all

while opening Identity Mapping getting this error can anyone will help me to resolve the issue.

Error is Identity Extended.hbm.xml attribute termdate has redundant numeric column mapping extended1
Thanks you kudos.

It looks like you have defined 2 different attributes with the same extended number in you identity config.
If you go to DEBUG page


find Identity

look for duplicated extendedNumber attributes like here

Second place to check is in identity hbm file - it is located here
image

You might have some duplicated names here
image

here also


in this below Obect i didn’t found any duplicates

Hey Shiva, Share the screenshots of “IdentityExtended.hbm.xml” file present in “webapps\identityiq\WEB-INF\classes\sailpoint\object”

Hi Shiva,

Please share the full code(uncommented) of IdentityExtended.hbm.xml file if possible.
There might be redundant declarations of extended attribute.

I found it for mover in my case. Removed the additional declarations and issue was resolved.

Thanks,
Deepak

Hi Shiva,

The Variable is of type String, Pls check if uncommented line

<property name="extended1" type="string" length="450" index="spt_identity_extended1_ci"/>

if you can share that file here then best for us to find the root cause.

In your Identity ObjectConfig, make sure that:

  1. You do not have 2 different attributes mapped to the same extended1 column (for example, the same extendedNumber=“1” property on 2 different tags)

  2. You do not have one attribute mapped to more than 1 extended1 column (for example, the same repeated, each with the same extendedNumber=“1” property, or one with 2 extendedNumber properties)

  3. You do not have one attribute mapped to an extended1 column and also mapped to a named column (for example, the same with extendedNumber=“1” and namedColumn=“true” properties)

Also make sure the .hbm.xml doesn’t have similar issues. When you go to Global Settings > Identity Mappings and click Save, this automatically maps each attribute to the next available extended attribute as defined in your .hbm.xml file, so that most likely fixed your issue

Also sometime this is false error , you click on Attribute mapped extended1 and then click on save , may be this error will be gone .

1 Like

This resolved my issue. I was using 2 tags: extendedNumber=“1” and name=“extended1”.
Also, had some unused attributes in the*.hbm.xml. Commented the entries.

2 Likes