Failed Profile Separation Task

Which IIQ version are you inquiring about?

Version 8.2

Share all details related to your problem, including any error messages you may have received.

We are trying running the Role Profile Separation task to separate all profiles within bundles. However, we are continuously getting the below error where the ID changes. Is there a fix to this?
We ran the IDX Integrity Checker rule as well where multiple lines of errors came back so I think I opened a can of worms, but I’m not sure what my next steps are. Any help would be appreciated!

Error: deleted object would be re-saved by cascade (remove deleted object from associations): [sailpoint.object.Profile#0a51b10988df192e81890f4a884f5e1c]
Error IDX Rule: NULL parent fk, idx: spt_profile idx, Gap/Missing IDX value in spt_link, idx:

Hi @Alyson_Trad,

The error shown is related to an incorrect way of deleting a Profile-object.

Can you elaborate a bit on the ‘Role Profile Separation’-task? As I can not recall this as a task provided OOTB, it looks like an custom task. If it is a custom task, can you share the source code of it, so we can help you with your issue.

Fo the IDX Integrety Checker issues, please look at: Correct IDX rule to detect and fix IDX values - Compass
Look at point 9:

If the task returns errors, then you would want to execute the task again with the options above, plus “update DB table rows to resequence ‘idx’ key-column” selected.


Please note that this task will only repair NULL IDX issues and cannot fix issues such as null parent foreign key issues, or similar items that may show up as warnings. These types of issues are not as critical as correcting the NULL IDX issues.


If you have any questions or comments regarding this rule, please open a ticket with SailPoint Support.

– Remold

The Profile Separation rule was custom made, we worked with a SailPoint associate for this. It separates profiles within a bundle.
I ran the IDX checker and it found 3 items which I then ran the corrector. It was successful and stated it fixed the IDX issues.

However, when running the separation task again, it is still failing on the below:
deleted object would be re-saved by cascade (remove deleted object from associations): [sailpoint.object.Profile#0a51b10988df192e81890f4a884f5e1c]

Can you provide the source of the ‘Profile Separation’-rule? So we can see what might be the issue?

If you want to format the format the code using the ``` around it, it would be great as it is better visible for all of us :slight_smile:

– Remold

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.