Can you guys please open-source the IIQDA Eclipse plugin?

Cross-posting this from Compass

There have been no updates to the plugin since the latest “beta” 4.0.3 in Feb 2019. At that time, someone commented that SailPoint was considering open-sourcing the product so that they wouldn’t have to keep maintaining it internally.

At some point, an Eclipse update is going to break the plugin. It already has some serious bugs that cause Eclipse to throw NullPointerExceptions and ClassCastExceptions in some situations, notably when the SSF FieldValue Framework is used. It inserts extra newlines into XML files on extract. It requires a plain-text password (ECLIPSE_PASS) to be in the target properties file, which is typically checked into source control.

I’d certainly be happy to contribute updates. I really want the handful of bugs fixed.


Hi @drosenbauer,

I think open sourcing our plugin is a great idea, and would love for you and other community members to help maintain it. I just wanted to let you know that I am working with our team to identify a maintainer and get this through our open source legal committee. I’ll keep this topic updated as we progress.


If you were to open source it, you would have me and my peers’ support in helping to enhance and maintain.

1 Like

there is also an extension for Visual Studio Code existing. Not sure if you already know: GitHub - lispercat/sailpoint-iiq-dev-accelerator: VSCode extension to accelerate and facilitate development by directly interacting with the target Sailpoint IIQ server



@colin_mckibben What’s the latest on this? It appears this plugin is unusable in 8.2p2 due to core IIQ API changes and could probably be fixed if it was already open-source. Related thread:


@colin_mckibben Any updates from your side on this?

I see this. Let me see what I can find out. Just a heads-up, many team members are participating in an internal activity this week and I don’t have full access to them; it might take me a few days to get you an update. Let you know as soon as I do.

1 Like

Thank you. Appreciate the heads up.


Tried to use IIQDA today with IdentityIQ 8.3, lots of things are broken. Import artifact doesn’t work, deploy artifact will sometimes timeout for no reason, XML files have a ton of empty lines, etc.


Anything change with this, Colin?

1 Like

I can give an update here.

We are just waiting on some legal approvals to be in place to finish up our open source process.

Once that is in place, it will be the last thing we need to do to start open-sourcing some tools. We have an internal deadline of the first week of March, so I expect that it will be done far before then.


Hey! Excited to hear about this. is there any updates that might suggest march is still expected as a valid date?

@ryan2000, yes! We are still expected to finish our legal work on open source in March, and then the fun can begin!

1 Like

Any updates with the open sourcing? I’m very excited, but a bit worried since it’s now mid-April and still no updates. Thanks!

Hey Eric,

Fret not, I have good news! Our product leadership has approved our open source initiative, as has our legal team. We have to get an internal process in place now to actively review an item for release, and we’re doing that now.

Admittedly, it has taken longer than I anticipated. But the good news is, this plug-in is number one on the list for items to review as soon as our process is in place.

Be excited, it is coming!


Hi Jordan,

Is there any update on this?

Hello, any update? We are advacning with IIQ past 8.2p2 and would love to have something to use like we did for the deployment accelerator.

While you wait, there’s an excellent open-source VSCode plugin that’s nearly as feature-complete as the Eclipse one.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.