Web Service connector: HTTP 415 Error

Hi
I am using IIQ 8.02 and trying to connect to an API via web service connector.
i tried Authentication Method : oauth2
grant type: client credentials/ password ( i tried both)
while doing test connection i am getting Error: Exception occurred while getting response for url: shnapi/rest/external/api/v1/token?grant_type=XXXXX&token_type=ABC and the exception is : Unable to generate access token. Response returned: {“code”:415,“message”:"The server is refusing to service the request because the entity of the request is in a format not supported by the requested resource for the requested method"}
i tried adding below attribute in app xml but no success






P.S: i am able to get the token thru postman.

Appreciate any help here.
thanks
Rakesh

1 Like

Hi Rakesh, it looks like the screenshot was not correctly attached to your post. Can you re-post the screenshot or add the configurations you made in text?

Hi Paul
thanks for reply. i was trying to mention in post earlier that i added oauth_headers with key=“Content-Type” value=“application/json” but no success.

Have you tried setting the Content-Type as “application/x-www-form-urlencoded”?

Hi Paul
i tried adding Content-Type as “application/x-www-form-urlencoded” to oauth_headers but the error remains the same.

Hey @rakeshbiswal,

This error appears to be a configuration issue, as opposed to a simple support issue. The next steps for resolving this error would most likely be to have a sit-down session with a member of the professional services team where they could dive in and investigate in greater detail. You can visit Professional Services | SailPoint for more information and requesting assistance.