Unable to access Identity from WebServices Connector After Rule


here it is
log.error("xxx processedResponseObject " + processedResponseObject);

printed out
xxx processedResponseObject [{id=3060}]

Which is the right value.

That’s interesting. Ideally it should be visible in the accounts tab now, since it is processed.

any logging I can enable or put somewhere to see what is going on?

Try enabling these 2 loggers


I went back to trying to update the link manually. The problem is the link isn’t there yet. I thought it would be created in the ‘afterRule’ But it isn’t there.

  for (Link link : links) {
            log.error("xxx link names " + link.getApplicationName());

example output:
xxx link names MobileLinc
xxx link names EntDir
xxx link names HSPDDM

That code shows all the links of the identity I am working on in the afterRule. the new app isn’t there. It does get created though and I see the link in the gui and on the identity xml in debug.

Should it be there in the afterRule on the WS connector? I am guessing that is why iiq can’t update it in the response map either.

Hi @Seadog

I would suggest checking couple of things.

  • What is the successful Response code from the API response and what is mentioned in Sailpoint IIQ? Are they matching?
  • Enable the loggers for Provisioning operation along with Webservice Loggers to check the ProvisioningResult in the provisioningPlan.

the test harness I built in python shows that on a successful create the service returns a 201. I’ve tried setting the successful response code in iiq to 201 and 2**, neither worked. Right now it is currently blank and it doesn’t work.

Can you please share how to do this?

Enable the loggers for Provisioning operation along with Webservice Loggers to check the ProvisioningResult in the provisioningPlan.

You can add the following loggers in log4j.properties file.



Please refer this https://community.sailpoint.com/t5/Working-With-Support-Knowledge/Log4j-Support-Guide/ta-p/137421 to understand more on Log4j.

If you are testing in lower environment, you can even add the below statement in AfterProvisioningRule to view the ProvisioningPlan with result.

    System.out.println("ProvisioningPlan = " + plan.toXml());

tracing.txt (5.5 MB)

I’ve uploaded some traces. It printed out quite a lot of data.

Hi @Seadog

The issue is because the ProvisioningPlan is not having nativeIdentity. The attributes are case-sensitive.
The identity attribute in the schema is employeeNumber and that in provisioningPolicy is employeenumber. Change the employeenumber to employeeNumber in provisioningPolicy.

Hi @Seadog
Is the issue fixed?

No, I got rid of that message but the id is still not getting updated on the link.

aug25.txt (13.4 KB)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.