REST API for adding identity attribute mapping in Identity Profile

Hi IdentityNow Experts,

I am trying to add a new attribute mapping in Identity Profile via API but in vain. I tried using the update identity profile API ( and it added the mapping in identityAttributeConfig/attributeTransforms in the identity profile. But it is not effective from the UI.

Is there another API to add a new attribute mapping to designated identity profile? Any suggestions are welcome, thank you.


Have you tried adding it directly form UI ?
Identities → Identity Profile → Select you Profile name and in Mappings tab you and add/edit the desired attribute. Once mapped Save and Apply changes.

That’s the easiest way to map it i would say.

Welcome to the developer community Ronald,

As Sharvari said, adding identity attribute mappings is easiest to do in the UI. I’m curious to understand why you would want to do this via API. Is there a need to automate identity attribute mappings?

Thanks Sharvari, yes it is the easiest when doing in UI. But we have use to API to achieve the same result, do you have any idea?

Please try using the V3 API to export the Identity Profile then add your identity attribute to the mapping in the response JSON and Import it back.

Hope this helps!

What @sharvari should work, but update-identity-profile | SailPoint Developer Community should work. Can you please share the request body you used and the resulting response?

Thanks your the reply. Sorry for the confusion, I am not asking to add an existing identity attribute to the identity profile. The v3 api is working for adding existing identity attributes to identity profile for sure.

But I am asking to add a “new” attribute that is not even created in the identity profile yet. I have already tried to use the v3 api but it is not working for new attributes. What I have to do is to use the cc/api/identityAttribute/create to create identity attribute first and then update the mapping in identity profile

@ronaldchuiASB. Can you please submit a support ticket? This appears to be a bug.