OOTB Webservice Connector Does not able to pass all fields

Hi All,

We are configuring a web service connector .During create operation we are able to pass all field from the create profile.
However during update operation or enable operation all fields are not populating in the body due to which the api call is failing.
We have also tried to add the fields in the Account Profile for all the operation but still the data does not pass.

Let us know if any suggestion.

Thanks
Shantanu

Hi @shantanu_ne ,

Welcome to the community.
In your update profile, for required attributes set “isRequired”: true & try.

Regards,
Anamica

Thanks Anamica,

But when we try to update it via API it never gets updated to isRequired as true even after successful response
Is there any API which can help to update this.

Thanks
Shantanu

I don’t think there is anyway to circumvent this behaviour of connector. The new api to set provisioning policy is also not updating the field. I also tried another field from old doc and it’s also not working.

 {
            "name": "departmentNumber",
            "transform": {
                "attributes": {
                    "value": "G&A"
                },
                "type": "static"
            },
            "attributes": {
                "cloudRequired": "true"
            },
            "isRequired": false,
            "type": "string",
            "isMultiValued": false
        }

The only way forward here is to put the attributes inside arguments of plan which connector does not strip.

is the only way to fix this is what Chirag mentioned?

Web Services connectors suddenly stopped working from several clients, and new connectors doesnt pass the values too.

The options we used was using a before provision rule to pass the mandatory attributes before every operation.
This way we could resolve our issue.

Thanks
Shantanu

https://ideas.sailpoint.com/ideas/CONN-I-66 Created idea to make plan arguments available in connector end point.
Also created this: https://ideas.sailpoint.com/ideas/PLAT-I-68
BTW, you do not need to write before provisioning rule to add arguments. You can use “services standard before provisioning rule” and configure your source json based on your requirement.

Hi @AnamicaShroti ,

I’m experiencing a similar issue in which, when executing an Update operation, the only attributes I’m able to retrieve using “$plan.xxx$” are nativeIdentity and group. Since the Create operation is never executed, the Provisioning Policy (create account) is never executed either. Doesn’t really matter if I change the attributes to “isRequired” or not.

Is there a way to pass account attributes in the body/parameter without the need of using the create account? Something that’d look something like: “$account.xxx$” (xxx in this case is an attribute only available in the account).

Looking forwrard to your comments!

Thanks,
Gregorio