Issues running Remote powershell -

Which IIQ version are you inquiring about?

Version 8.X

Share all details related to your problem, including any error messages you may have received.

I am using Azure AD connector application to run a Powershell script directly using IQService. The IQService receives the script but not running it.
The error I see in the logs is

“Exception occurred in executing the script : The input is not a valid Base-64 string as it contains a non-base 64 character, more than two padding characters, or an illegal character among the padding characters”

Any suggestion to resolve this, as I think this error is not because of the powershell script or the beanshell rule executing it but because of the connector.

Thanks in advance,

@jjarabo : Hello Jose, I see similar post from you where you also got the exact same error. But I do not see any solution in that post, were you able to resolve this issue?

Referring to this post: Issues running Remote powershell after upgrading from 8.0->8.3p3

can you share your code ?

Thank you for your response.
I have attached the Supporting rule to call the powershell script and the powershell script files here.

Rule-Connect-ExchangeOnline.xml (1.6 KB)
Rule-Support-Connect-ExchangeOnline.xml (3.9 KB)


If you change the powershell script to just be as basic as possible, like write to a log, does it that work?

Hello Jarrett,
Yes I tried with only a basic powershell command, like Get -Mailbox, but still same error.

The powershell script is getting loaded on the IQservice machine but always the same error.


please remove this line from the Rule-support-connect-ExchangeOnline

public AccountRequest buildDummyPayload(SailPointContext context, Application baseApplication, String accountName) throws GeneralException {
	        AccountRequest payload = new AccountRequest();
	        //payload.add(buildParamAttributeRequest("base_username", "dummyUsername"));
	        //payload.add(buildParamAttributeRequest("base_password", "dummyPass"));
	        payload.add(new AttributeRequest("FakeAttribute",Operation.Add, "Fake Value"));
	        return payload;

Please try and let me know if that works for you.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.