Issue/Bug in WebService Connector - SailPoint IDN

Hello All,

Recently, facing an issue in the production that we are not able to perform enable/disable operations for web service connected applications.

Getting the below error “Required request body is missing: public void” while I try to disable/enable an account.


However, I could see the request body in the disable operation. Somehow, SailPoint IDN is not able to pass the body data, which was not the case a some weeks before.

Also, I have tried to reproduce the issue via postman and found that when we left the body as empty we received the error message.

Kindly suggest what would be the possible solution for this issue.


Hello @kannan_sb85,

I believe the UI update caused the raw post body to change using the &qout; notation instead of the actual character " around your key value pairs. Can you replace all &qout; instances with ". I suggest copying your post body into an editor and using the find/replace to make it simple.

For example:


I suspected that and tried already unfortunetly that is not helped.

If that is the case, submit a support ticket here. They will be able to take a closer look at your environment and logs to determine the cause.

1 Like