Anyone have experience installing IIQ 8.4 on JBoss

Which IIQ version are you inquiring about?

Version 8.4

Share all details related to your problem, including any error messages you may have received.

Does anyone have experience installing 8.4 on JBoss that would be willing to share their experience customizing the iiq.properties file and customBeans.xml file to implement the JNDI data sources? (Not the JDBC data sources, like on tomcat)

(apis tag is not applicable, but had to add a second)

I did,

Pretty bad experience. Honestly just install in tomcat or contenarize IIQ

I figured out the install process but the deployment and startup is the problem.

Yeah , thats was also my problem, there was some incompatibilities on some libraries

Both JBoss Enterprise 7.4 and 7.3 are supported by SailPoint. SailPoint Support should be able to help with the install.

I assume you read the special JBoss section in the installation document for 8.4. Specially:

Note: Previously supported releases of JBoss Application Server required configuration that is no longer required in the Application Server versions supported in this release. If you use older unsupported versions of JBoss, the additional configuration, defined in previous versions of the IdentityIQ Installation Guide, are still required.

You did not mention which JBoss version you are using, but if it is below 7.3 I would upgrade yo at least 7.3 :wink:

– Remold

2 Likes

Hi Keith, We installed 8.3 (not 8.4 TBH) on JBoss and it was working perfectly with no issues, some challenges in the beginning but then went smooth.

Also as mentioned by Remold “Both JBoss Enterprise 7.4 and 7.3 are supported by SailPoint. SailPoint Support should be able to help with the install”.

Have a nice and great one!