ADP HR Source Failure-Certificate and Private key Format

Hello All,

We have ADP as our HR Authoritative source in our IDN env. It has been failing to connect with SSL handshake error due to expired certs. We created CSR and RSA Private key (PEM format) and got cert issued from ADP in PEM format. When we plugged both cert and private key into connector config we are seeing “Unable to process private key” error.

We followed all the steps given in connector documentation and in KB0011636. However, still no resolution. We did not have proper documentation and procedure defined when this configuration was made for the first time therefore we are pretty much dead in water. Does anyone know what content of both files should look like?

Has anyone experienced same issues with ADP in IDN? Are we missing something?

1 Like

We were able to fix this. Looks like connector documentation has commands for OpenSSL version 1.1. If you are using OpenSSL version 3 or more command to convert traditional key into RSA pem is “openssl rsa -in traditional_auth.key -out rsa_converted.key -traditional”.


Thank you for sharing how you solved this!