Troubleshooting the IdentityNow Bulk Access Profile and Role Importer

Hi Experts,

The IdentityNow Bulk Access Profile and Role Importer which is a ruby based automation for creating or updating roles/APs in bulk sometimes gets an SSL error, and in some cases, at least in the older versions, REST API structure issues where the pagination wasn’t working.

Is the above linked page the latest version where this utility is being maintained by SailPoint, and is the SSL error something the troubleshooting section of the file capable of resolving? I’d love to hear the thoughts and experience of anyone who faced such an issue and how you overcame it, and would appreciate the best practices/tips & tricks around the use of this utility.

Yes, that’s the latest version of the script updated by Sailpoint.

As far as pagination issues in the older versions of script, we fixed them on our side by modifying the ruby script and making it work for our tenant but that was a while ago and I believe it may have been fixed by now.

Also, I haven’t come across any SSL error but have you already tried the troubleshooting steps mentioned in README file to resolve your error? Did it not work for you?

I haven’t tried the following steps provided in readme yet, but will update when I do:

But, adding the following line to the code, after the line http.use_ssl = true, it worked:
http.verify_mode = OpenSSL::SSL::VERIFY_NONE
Note: This disables SSL verification so it isn’t the most secure way to get around this error.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.