Message: Connection reset, HTTP Error Code: 0

We onboarded a web services application to IIQ and though all the required credentials are fine. It gives the following error.

Exception occurred in Test Connection.Url: https://, Message: Connection reset, HTTP Error Code: 0

Tested and the connectivity works fine when tried through POSTMAN on the application host

Application certificate is also installed on our application host.

Tried adding additional logger as below but doesn’t help much but giving web connector detailed logs.

Option 1:

Option 2:

Hey @ampandey, thanks for posting your first question. Let us do some investigating, and we will hopefully be able to come back with some insights for you shortly.

Hi @ampandey,

What version of IIQ are you running?

If 8.x, you can try the following loggers in your file.

For IIQ 7.x add these loggers to your and reload logging for them to take effect.

Also, if you do a test from iiq console, we may get additional information as to why it is failing:
./iiq console

connectorDebug “applicationName” test


1 Like

@ampandey : Are you still facing this issue ? if this is still an issue can you please confirm the TLS version used at end application is same as in SailPoint /IIQ.

@ampandey were you able to resolve this issue? Is there any further guidance we can offer for you?

How should I check the TLS version on SailPoint End?

This is still not resolved

By default IQService enforces TLS version 1.2 with Java version 1.8 on IdentityIQ / Cloud Gateway.


Hope, this is helpful.

Hey @ampandey

I wanted to check in and see if you were able to make any progress on this project. Please let us know and if we can be of any further assistance to you.

Hey @ampandey,

I am marking this thread as resolved. Please let us know if we can be of any further assistance to you.