Identitynow JDBC source test connection issue

Hi all,

I have been trying to setup JDBC source in IdentityNow. Not sure where I am going wrong so if anyone can help me with the below problem it will be really helpful. While trying to test connection for a JDBC source connected to Mysql database getting below error.


We have detected an error from the managed system.
Error Received:

Timeout waiting for response to message 9 from client 02bxxbaf-xxxx-xxxx-xxxx-8724xxxxfc41 after 15 seconds.

Below are the details of the VA

I have a VA cluster with 2 VA’s in it 1 VA is healthy.

VA on an IP Address ( , Able to ping MySQL IP from this VA.

Below are the details of the MySQL

MySQL is on IP (, Able to ping VA IP from this side as well.

I am using root user to login with a password.

DB Name : db1

Table name : MyTable

Below are the details of the source setup

Base Configuration

Source Name : MyAccessJDBC

Source Description : MyAccess JDBC data source

Source Owner : SBahl

Virtual Appliance Cluster : TestVACluster2

Governance Group for Source Management :

Uploaded Files : mysql-connector-j-8.0.31.jar


User Name : root

Password : ***************

Database URL : jdbc:mysql://

Driver Class : com.mysql.cj.jdbc.Driver

Additional Connection Parameters :

Test Connection SQL Query : show databases;

Use Stored Procedure for Test Connection SQL Query : false

Account SQL Query : select * from MyTable;

Use Stored Procedure for Account SQL Query : false

Single Account SQL Query :

Use Stored Procedure for Single Account SQL Query : false

Use executeQuery : false

Enable Direct Permission : false

Enable Delta Aggregation : false

Please let me know if any more info is required for this.

You can try and increase the timeout limit: JDBC - Stored Procedure - #2 by AnamicaShroti

@colin_mckibben : I have already tried increasing the timeout, Still it gets timeout after 15 secs even after setting the value to a higher side.

Hi Shivam,

Were you able to resolve this error ? I am getting the same error

I am also getting same error,when I tried to ping the server in cmd I am getting time out error

Nope. Just rename the JAR file upload it from UI and just wait for 2 mintues and the save.try to test the connection. this resolved my issue

thank you @sabthami subramanian

but is the ping from your VA server to the DB works or not ?

if not it could be some firewall rules issue which could block the connection.