Azure AD Account Aggregation Error

Which IIQ version are you inquiring about?

Version 8.2

Share all details related to your problem, including any error messages you may have received.

Hi All, does someone experience when running Azure AD Account Aggregation, they get this error below:

Exception during aggregation of Isabel Aguilera. Reason: org.hibernate.exception.JDBCConnectionException: could not prepare statement

Hi @pbobadil ,

Are you using any aggregation rules?? Also have you already set up Rapid setup configurations??

Sometimes I used to get the same error, a simple fix for me was to remove the rapid setup configurations, and then set it up once the aggregation was done…

Hi Hardik, we don’t have the Rapid Setup configuration yet configured on our Prod Environment.

Have you added any Identity mappings in your instance as Azure AD in a source mapping?

We haven’t added any new ones on our Identity Mappings.

@pbobadil Does it get stuck from the beginning or only with that user?

It’s get stuck on some of the users then failed.

@pbobadil do you have Service principle and Serviec plan in schema ? Also, check if in schema if you have riskLevel, riskState, riskDetail, riskLastUpdatedDateTime. Sometime create this attributes so try to remove then try. Also creationType - remove this also.

Solved: Azure Active Directory Aggregation Failure - Compass (sailpoint.com)