API Specs

I have some problems to execute account details order in the next url: get-account | SailPoint Developer Community

I use: https://{{tenant}}.api.identitynow.com/v3/accounts/:id and the value i tried with different values, i tried with https://{{tenant}}.api.identitynow.com/v3/accounts?id and it didn´t work too. is it correct the next API build?

curl -L -X GET ‘https://sailpoint.api.identitynow.com/v3/accounts/:id
-H ‘Accept: application/json’
-H ‘Authorization: Bearer ’

I’m not sure I understand what you’re asking, but it seems you’re trying to use id as a query parameter on the list accounts endpoint. It’s not a valid query parameter, you have to use filters

/v3/accounts?filters=id eq “:id”

You should be able to use

curl -L -X GET ‘https://sailpoint.api.identitynow.com/v3/accounts/123703f183b043509b29ea8445d8650e’
-H ‘Accept: application/json’
-H ‘Authorization: Bearer ’

Where “123703f183b043509b29ea8445d8650e” is the ID of the identity from the URL in the standard interface as well as the id value returned from a generic https://sailpoint.api.identitynow.com/v3/accounts call which will return a list of accounts that you can grab a single ID from

1 Like

Seems like there is a confusion between accountId and identityId here. However, you can get the details of a specific account using any one of these using beta or v3 version of the API {{baseUrl}}/{{api_ver}}/accounts along with

accountId as a path parameter
---------------------- or ----------------------------
identityId with the query parameter filters
{{baseUrl}}/{{api_ver}}/accounts?filters=identityId eq "de0d09510a594b66ab4c7ceb0c8231ba"

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.