# Error while enabling account

**URL:** <https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143>\
**Category:** SHF Discussion and Questions\
**Tags:** provisioning, identity-security-cloud\
**Created:** [April 8, 2025, 4:43pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143 "2025-04-08T16:43:24Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![nileshnikalje](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/nileshnikalje/32/24406_2.png) [@nileshnikalje](https://developer.sailpoint.com/discuss/u/nileshnikalje)\
**Post date:** [April 8, 2025, 4:43pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/1 "2025-04-08T16:43:24Z")

</div>

I am receiving the following error while enabling/disabling the account on a source.

 ![image](https://global.discourse-cdn.com/sailpoint/original/3X/b/1/b13e2e9602c0b3f7cf96dd22873839683c1ddbe0.png)

There was an error trying to enable the account

An unexpected error occurred: failed to lazily initialize a collection of role: sailpoint.object.Identity.links, could not initialize proxy - no Session

I believe this is the root cause of lifecycle state transaction not going through. Whenever i try to change the lifecycle state, as per the provisioning policy mentioned in identity profiles, it should disable/enable the account. It is not getting triggered. In the account activity i see that the lifecycle state change account activity is pending for ever.

 ![image](https://global.discourse-cdn.com/sailpoint/original/3X/8/0/80941e99aba4531c981e6bf15ed14309794bf7e2.png)

---

<div class="post-metadata">

**Author:** ![vsandhu1](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/vsandhu1/32/8295_2.png) [@vsandhu1](https://developer.sailpoint.com/discuss/u/vsandhu1)\
**Post date:** [April 8, 2025, 6:52pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/2 "2025-04-08T18:52:57Z")

</div>

Hi Nilesh, what kind of account are you trying to initialize?

---

<div class="post-metadata">

**Author:** ![nileshnikalje](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/nileshnikalje/32/24406_2.png) [@nileshnikalje](https://developer.sailpoint.com/discuss/u/nileshnikalje)\
**Post date:** [April 9, 2025, 5:27am UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/3 "2025-04-09T05:27:32Z")

</div>

I am trying to enable webservices account.

The issue occurs while I try to manually enable the account or set the lifecycle state to Active.

Regards,

---

<div class="post-metadata">

**Author:** ![RAKRHEEM](https://avatars.discourse-cdn.com/v4/letter/r/f05b48/32.png) [@RAKRHEEM](https://developer.sailpoint.com/discuss/u/RAKRHEEM)\
**Post date:** [April 9, 2025, 6:28am UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/4 "2025-04-09T06:28:50Z")

</div>

Hi Nilesh,  
Can you share the screenshot of the configuration done for Disable Account on the Web Service Connector ? Also, have you tested the Disable Operation directly in Postman and it works fine ?

Thanks

---

<div class="post-metadata">

**Author:** ![nileshnikalje](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/nileshnikalje/32/24406_2.png) [@nileshnikalje](https://developer.sailpoint.com/discuss/u/nileshnikalje)\
**Post date:** [April 9, 2025, 6:53am UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/5 "2025-04-09T06:53:29Z")

</div>

Yes. the create/disable/enable operations work in Postman. I just now tried to assign a role to a user that should create an account in the source. Got the same error.

 ![image](https://global.discourse-cdn.com/sailpoint/original/3X/4/0/40dd19fd7f0c437814e467c428a9eee2ba63db39.png)

This was working and suddenly stopped working. Looks like issue with the tenant

---

<div class="post-metadata">

**Author:** ![Arshad](https://avatars.discourse-cdn.com/v4/letter/a/b9e5f3/32.png) [@Arshad](https://developer.sailpoint.com/discuss/u/Arshad)\
**Post date:** [April 9, 2025, 7:44am UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/6 "2025-04-09T07:44:27Z")

</div>

> [@nileshnikalje](#):
>
> I am receiving the following error while enabling/disabling the account on a source.

I too am seeing this below error randomly during access requests which looks more or less similar to yours:

![image](https://global.discourse-cdn.com/sailpoint/original/3X/5/e/5e26447d5a42389cc360dd478ef56ef73f767696.png)

And I was not seeing this issue couple of days ago but with the same scenario replicated yesterday, I am seeing this. Any insights would help.

Thanks,  
Arshad.

---

<div class="post-metadata">

**Author:** ![nileshnikalje](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/nileshnikalje/32/24406_2.png) [@nileshnikalje](https://developer.sailpoint.com/discuss/u/nileshnikalje)\
**Post date:** [April 9, 2025, 10:30am UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/7 "2025-04-09T10:30:50Z")

</div>

Is this webservices connector?

---

<div class="post-metadata">

**Author:** ![Arshad](https://avatars.discourse-cdn.com/v4/letter/a/b9e5f3/32.png) [@Arshad](https://developer.sailpoint.com/discuss/u/Arshad)\
**Post date:** [April 9, 2025, 10:31am UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/8 "2025-04-09T10:31:33Z")

</div>

Yes, this is on webservices connector.

---

<div class="post-metadata">

**Author:** ![nileshnikalje](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/nileshnikalje/32/24406_2.png) [@nileshnikalje](https://developer.sailpoint.com/discuss/u/nileshnikalje)\
**Post date:** [April 9, 2025, 10:47am UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/9 "2025-04-09T10:47:48Z")

</div>

This is happenning for Webservices connector and not for other ones. For instance access requests on JDBC connector are working fine

---

<div class="post-metadata">

**Author:** ![nileshnikalje](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/nileshnikalje/32/24406_2.png) [@nileshnikalje](https://developer.sailpoint.com/discuss/u/nileshnikalje)\
**Post date:** [April 9, 2025, 10:48am UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/10 "2025-04-09T10:48:15Z")

</div>

I tried recreating the source but no success

---

<div class="post-metadata">

**Author:** ![Arshad](https://avatars.discourse-cdn.com/v4/letter/a/b9e5f3/32.png) [@Arshad](https://developer.sailpoint.com/discuss/u/Arshad)\
**Post date:** [April 9, 2025, 11:07am UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/11 "2025-04-09T11:07:59Z")

</div>

Same, we tried to clone the source config and re-tried but same issue was observed. We tried to perform a full identity refresh, full system role refresh but no luck. I’m doubtful if this has something to do with issue with Web Services connector behind the scenes.

---

<div class="post-metadata">

**Author:** ![Abhishek\_1995](https://avatars.discourse-cdn.com/v4/letter/a/d26b3c/32.png) [@Abhishek\_1995](https://developer.sailpoint.com/discuss/u/Abhishek_1995)\
**Post date:** [April 9, 2025, 11:29am UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/12 "2025-04-09T11:29:21Z")

</div>

Hi @nileshnikalje,

If you are enabling the account getting the error once do the Account aggregation. The account will be enabled.

Thank you!

---

<div class="post-metadata">

**Author:** ![nileshnikalje](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/nileshnikalje/32/24406_2.png) [@nileshnikalje](https://developer.sailpoint.com/discuss/u/nileshnikalje)\
**Post date:** [April 9, 2025, 12:02pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/13 "2025-04-09T12:02:32Z")

</div>

Here is the latest observation. The account is created in the source. However there is no event generated for Create Account for the identity. This does not trigger “Provisioning completed” event which is used in workflows to send emails. The access request still has the same error.

 ![image](https://global.discourse-cdn.com/sailpoint/original/3X/0/b/0b1e70eb4499f01d79e8b5351fcffe00b921bb45.png)

---

<div class="post-metadata">

**Author:** ![bastienprulhiere](https://avatars.discourse-cdn.com/v4/letter/b/9d8465/32.png) [@bastienprulhiere](https://developer.sailpoint.com/discuss/u/bastienprulhiere)\
**Post date:** [April 9, 2025, 12:28pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/14 "2025-04-09T12:28:25Z")

</div>

Hi,

We also have this issue on our context for different operation (submit request, account creation, disable account).

A ticket has been opened to Sailpoint support.

---

<div class="post-metadata">

**Author:** ![nilesh\_markel](https://avatars.discourse-cdn.com/v4/letter/n/3e96dc/32.png) [@nilesh\_markel](https://developer.sailpoint.com/discuss/u/nilesh_markel)\
**Post date:** [April 9, 2025, 3:47pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/15 "2025-04-09T15:47:15Z")

</div>

Any update on the ticket?

---

<div class="post-metadata">

**Author:** ![Noemi](https://avatars.discourse-cdn.com/v4/letter/n/7ab992/32.png) [@Noemi](https://developer.sailpoint.com/discuss/u/Noemi)\
**Post date:** [April 10, 2025, 1:40pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/16 "2025-04-10T13:40:46Z")

</div>

Any update? I have the same issue

---

<div class="post-metadata">

**Author:** ![nileshnikalje](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/nileshnikalje/32/24406_2.png) [@nileshnikalje](https://developer.sailpoint.com/discuss/u/nileshnikalje)\
**Post date:** [April 10, 2025, 7:07pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/17 "2025-04-10T19:07:50Z")

</div>

Please raise a Sailpoint ticket, I raised it two days back. Its been referred to their engineering team. Please mention this topic while raising the ticket to let them know that others are also facing the same issue.

I assume you are getting the same error on Webservices connector.

---

<div class="post-metadata">

**Author:** ![nileshnikalje](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/nileshnikalje/32/24406_2.png) [@nileshnikalje](https://developer.sailpoint.com/discuss/u/nileshnikalje)\
**Post date:** [April 10, 2025, 7:09pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/18 "2025-04-10T19:09:05Z")

</div>

Is this also for Webservices connector?

---

<div class="post-metadata">

**Author:** ![gmilunich](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/gmilunich/32/8431_2.png) [@gmilunich](https://developer.sailpoint.com/discuss/u/gmilunich)\
**Post date:** [April 14, 2025, 3:27pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/21 "2025-04-14T15:27:15Z")

</div>

These Lazy Initialization errors are Hibernate errors that were usually caused by an account being decached improperly when they happened in IIQ.

Given that you don’t handle the identity directly in your code, it is likely there is something going on internally that is causing the process to close the session before the identity is done. Do you have a custom Before/After operations on your webservice connector (Assuming this is the DIrect Connector and not SaaS) that you are modifying data?

I would recommend that anyone with this issue create a Support Ticket with SailPoint to get this looked at since it seems to be happening with multiple accounts.

---

<div class="post-metadata">

**Author:** ![gmilunich](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/gmilunich/32/8431_2.png) [@gmilunich](https://developer.sailpoint.com/discuss/u/gmilunich)\
**Post date:** [April 14, 2025, 3:30pm UTC](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143/22 "2025-04-14T15:30:58Z")

</div>

> [@NandanaGopu](#):
>
> You’re changing the **Lifecycle State** in SailPoint IDN, expecting it to trigger provisioning actions (like disabling/enabling an account) based on the **Identity Profile’s Provisioning Policy** , but instead:
> 
> - The **Lifecycle State change shows as a pending Account Activity**
> - It never progresses or completes
> - No actual enable/disable action happens
> 
> This is a common headache in IDN setups, especially when combining **Lifecycle States** , **Provisioning Policies** , and **Web Service connectors**.
> 
> Let’s break it down and walk through possible causes and fixes.  
> …

This appears to be AI-Generated content and it is considered poor etiquette to just post AI responses like this. AI can be used to help you develop or check your response, but your response should be in your own words.

Additionally, in this case, your response does not appear to answer the question, and does not take in the information already presented.

On a second glance, it does not appear to discuss the issue the user is seeing at all, so it is not really helpful to this situation.

[Next page](https://developer.sailpoint.com/discuss/t/error-while-enabling-account/109143.md?page=2)
