# Active Directory Provisioning issue

**URL:** <https://developer.sailpoint.com/discuss/t/active-directory-provisioning-issue/29209>\
**Category:** SHF Discussion and Questions\
**Tags:** provisioning, identity-security-cloud\
**Created:** [February 6, 2024, 7:05pm UTC](https://developer.sailpoint.com/discuss/t/active-directory-provisioning-issue/29209 "2024-02-06T19:05:20Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![vdivakar](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/vdivakar/32/14308_2.png) [@vdivakar](https://developer.sailpoint.com/discuss/u/vdivakar)\
**Post date:** [February 6, 2024, 7:05pm UTC](https://developer.sailpoint.com/discuss/t/active-directory-provisioning-issue/29209/1 "2024-02-06T19:05:20Z")

</div>

Hi,  
We are getting following error while Active Directory accounts provisioning.

[“Exception occurred while executing the RPCRequest: Errors returned from IQService. Access is denied. Access is denied. . HRESULT:[0x80070005]”]

We have installed IQService and test connection and Accounts and Entitlement aggregation is successfull.

Has anyone faced issue like this before?

Any insights/solution is appreciated…

Thanks  
Vaibhav

---

<div class="post-metadata">

**Author:** ![amishra97](https://avatars.discourse-cdn.com/v4/letter/a/50afbb/32.png) [@amishra97](https://developer.sailpoint.com/discuss/u/amishra97)\
**Post date:** [February 6, 2024, 7:14pm UTC](https://developer.sailpoint.com/discuss/t/active-directory-provisioning-issue/29209/2 "2024-02-06T19:14:38Z")

</div>

@vdivakar

I would suggest first looking into the service account’s permission level. Does it have the right authorization to create AD accounts?

---

<div class="post-metadata">

**Author:** ![vdivakar](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/vdivakar/32/14308_2.png) [@vdivakar](https://developer.sailpoint.com/discuss/u/vdivakar)\
**Post date:** [February 6, 2024, 7:50pm UTC](https://developer.sailpoint.com/discuss/t/active-directory-provisioning-issue/29209/3 "2024-02-06T19:50:57Z")

</div>

Hi, Thanks for replying,

The service account have Full control and all other permissions to create the accounts in AD.

We also observed following error when we installed and start the IQService instance

RpcServer [Thread-1] ERROR : "Exception while listening:System.Net.Sockets.SocketException (0x80004005): Only one usage of each socket address (protocol/network address/port) is normally permitted

We are still able to do test connection, account and entitlement aggregation successfully, only account creation is failing.

---

<div class="post-metadata">

**Author:** ![amishra97](https://avatars.discourse-cdn.com/v4/letter/a/50afbb/32.png) [@amishra97](https://developer.sailpoint.com/discuss/u/amishra97)\
**Post date:** [February 6, 2024, 7:59pm UTC](https://developer.sailpoint.com/discuss/t/active-directory-provisioning-issue/29209/4 "2024-02-06T19:59:55Z")

</div>

@vdivakar

OK.  
So the error code now is different.  
Can you check, what is the port of IQService and is there any other service using the same port?

---

<div class="post-metadata">

**Author:** ![vdivakar](https://sea1.discourse-cdn.com/sailpoint/discuss/user_avatar/developer.sailpoint.com/vdivakar/32/14308_2.png) [@vdivakar](https://developer.sailpoint.com/discuss/u/vdivakar)\
**Post date:** [February 6, 2024, 8:22pm UTC](https://developer.sailpoint.com/discuss/t/active-directory-provisioning-issue/29209/5 "2024-02-06T20:22:04Z")

</div>

Hi  
The error resolved when we rechecked the permission, it was related to client’s infrastructure, we gave permissions, but it was reflecting late…

Accounts are being provisioned properly now…

Thanks,  
Vaibhav

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/sailpoint/original/2X/f/f2136700ed5e3703e0b85e02f6be799dacca7735.png) [@system](https://developer.sailpoint.com/discuss/u/system)\
**Post date:** [April 6, 2024, 8:22pm UTC](https://developer.sailpoint.com/discuss/t/active-directory-provisioning-issue/29209/6 "2024-04-06T20:22:24Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
